Aviso: La filosofía de este foro público de preguntas y respuestas, es que sea participativo. Pretendemos que la comunidad de usuarios de nuestros portátiles compartan su experiencia. Queremos ayudarles y a la vez recibir ayuda para mejorar. Gracias por participar, entre todos hacemos de este un lugar mejor.

 

Para más información sobre el sistema de puntos pulsa aquí


0

experto

Fallo al instalar Slimbook Touchpad

Alex On Domingo, 26 Junio 2016.
Categoría: Linux

Os comento:

Hace unas semanas instalé desde Slimbook Essentials los indicadores para  activar/desactivar el touchpad y para el bloqueo de mayúsculas. Al lanzarlos ninguno de los dos funcionaba. Unos días después actualicé el sistema (Ubuntu 16.04 instalado por vosotros/as) y entre las actualizaciones estaba la de Slimbook Essentials. Volví a instalar los dos indicadores y el del bloqueo de mayúsculas ya funcionó pero el del touchpad seguía sin arrancar, salía el icono en la barra lateral de Ubuntu durante unos segundos y luego desaparecía sin llegar a mostrar el indicador.

El problema lo he solucionado instalándolo directamente desde Synaptic. Al buscarlo me aparecía un signo de exclamación en la casilla de marcar para instalar y junto al indicador se han instalado unos paquetes de python que por lo visto faltaban. No sé si el fallo se habrá debido a haber intentado instalarlo con una versión antigua de Slimbook Essentials o si hubiese pasado igual. Siento no poder dar más detalles pero lo comento igualmente por si le pasa a alguien más.

Por otra parte me gustaría sugerir que, si se puede, se pongan atajos de teclado para activarlo y desactivarlo por si alguna vez se estropea el ratón y no hay posibilidad de conectarle otro. Sé que pueden configurarse los atajos independientemente del indicador pero ya que hay una aplicación que reliaza esta función, estaría bien que incorporara estos atajos.

Un saludo.

 

Respuesta más votada


2
STAFF

staff

Re:Fallo al instalar Slimbook Touchpad
alejandro On Lunes, 27 Junio 2016

Buenas Alex,

Lo primero muchas gracias por tu aviso!!

La actualización arreglaba las dependencias, así lo hicimos; pero si cuando actualizabas el SO, no te salía la actualización por algún motivo, no se podía arreglar.

Sobre el atajo de teclado, perfecto, tomanos nota! Lo haremos!
Aunque no puedo decirte cuando estará, ahora llega Julio y Agosto y algunos compañeros están de vacaciones y otros, lo estarán pronto. Vamos a ir más liados y estamos encajando tareas y proyectos.

 


Todas las respuestas

11 Respuestas.

2
STAFF

staff

Re:Fallo al instalar Slimbook Touchpad
alejandro On Lunes, 27 Junio 2016

Buenas Alex,

Lo primero muchas gracias por tu aviso!!

La actualización arreglaba las dependencias, así lo hicimos; pero si cuando actualizabas el SO, no te salía la actualización por algún motivo, no se podía arreglar.

Sobre el atajo de teclado, perfecto, tomanos nota! Lo haremos!
Aunque no puedo decirte cuando estará, ahora llega Julio y Agosto y algunos compañeros están de vacaciones y otros, lo estarán pronto. Vamos a ir más liados y estamos encajando tareas y proyectos.

 



1

experto

Re:Fallo al instalar Slimbook Touchpad
Alex On Martes, 28 Junio 2016

Tampoco hay prisa. Cuando podáis.



0

intermedio

Re:Fallo al instalar Slimbook Touchpad
Jesulínico On Lunes, 03 Abril 2017

Tengo un problema similar, a lo largo de un año que adquiri mi slimbook me ha dado problemas el touchpad, selecionando y borrando y saltando fuera de la pantalla. trate de corregirlo sin éxito instalando esta aplicación. La he actualizado hace poco y me sigue dando el siguiente error al ejecutar

/usr/bin/slimbooktouchpad:17: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk as Gtk
/usr/bin/slimbooktouchpad:18: PyGIWarning: AppIndicator3 was imported without specifying a version first. Use gi.require_version('AppIndicator3', '0.1') before import to ensure that the right version gets loaded.
  from gi.repository import AppIndicator3 as appindicator
/usr/bin/slimbooktouchpad:19: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
  from gi.repository import Notify as notify
Traceback (most recent call last):
  File "/usr/bin/slimbooktouchpad", line 38, in
    valor1 = str(int(config.get('CONFIGURATION', 'velocidad')))
  File "/usr/lib/python2.7/ConfigParser.py", line 607, in get
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: 'CONFIGURATION'

 



0
STAFF

staff

Re:Fallo al instalar Slimbook Touchpad
joanslimbook On Martes, 04 Abril 2017

Hola Jesulínico,

 

El problema esta en que no existe o esta vacío, el archivo de configuración.

 

En terminal introduce:

sudo nautilus ~/.config/slimbooktouchpad/

Comprueba que exista un archivo llamado: "slimbooktouchpad.conf"

Si existe, introduce dentro el siguiente texto:

[CONFIGURATION]

velocidad = 10

deccon = 1

decad = 1

hor = 0

conf = 0

 

En el caso de que no exista, crea el archivo con el nombre "slimbooktouchpad.conf" y introduce el texto antes citado.

 



0

intermedio

Re:Fallo al instalar Slimbook Touchpad
Jesulínico On Viernes, 07 Abril 2017

Gracias ahora puedo arrancar las aplicaciones. Tras la última actualización volvio a fallar, pero chivaba una a una las nuevas opciones que le faltaban a los respectivos archivos de configuracion.

En esta version 1.4 me sigue saltando el cursor igual, aunque tengo configurado que la aplicacion se ejecute al inicio, hasta que entro en el menú preferencias de la aplicación y clikeo en aceptar, entonces noto cambios, se mueve el cursor pero muy muy poco, teniendo que hacer varios barridos en el touchpad para abarcar un poco.

¿cómo hago para cambiar a libimput? la aplicación dice que sigo usando evdev



0
STAFF

staff

Re:Fallo al instalar Slimbook Touchpad
joanslimbook On Lunes, 10 Abril 2017

Hola Jesulínico, vamos a subir en breve una nueva versión con la que podrás elegir si usar libinput o evdev y algunas mejoras. Prueba en unas horas a ver si te sirve para solucionar esos errores.



0

intermedio

Re:Fallo al instalar Slimbook Touchpad
Jesulínico On Jueves, 27 Abril 2017

Nada, llevo tiempo probando la aplicación, slimbook toucpad version 1.5, ahora  funciona con libinput4. Tengo que seguir entrando en el menú preferencias y salir para que surjan los cambios, además se sigue produciendo los saltos, pero mucho mas suave.



0
STAFF

staff

Re:Fallo al instalar Slimbook Touchpad
joanslimbook On Viernes, 28 Abril 2017

Hola,

Solucionamos el error de preferencias, tal vez no se hayan copiado bien los archivos.

¿Podrias seguir estos pasos?

1 Enviame los valores introducidos en la pantalla de preferencias

2 Una vez reiniciado tu Slimbook sin abrir preferencias, introduce en terminal el siguiente comando y mandame los valores que te devuelva:

xinput --list

Busca el id del touchpad en la terminal e introduce el siguiente comando seguido del id (Numero)

xinput --list-props "id"

Ejemplo: xinput --list-props 12

Un saludo



0

experto

Re:Fallo al instalar Slimbook Touchpad
Alex On Martes, 09 Mayo 2017

Hola.

Me pasa algo muy parecido a Jesulínico. Tras una actualización de Slimbook Touchpad, dejó de funcionar. La diferencia es que no tengo ninguna carpeta llamada slimbooktouchpad dentro de ~/.config. La he creado y dentro he hecho lo propio con el archivo slimbooktouchpad.conf tal y como habéis indicado. Sigue sin funcionar y el error que sale ahora es:

/usr/bin/slimbooktouchpad:17: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk as Gtk
/usr/bin/slimbooktouchpad:18: PyGIWarning: AppIndicator3 was imported without specifying a version first. Use gi.require_version('AppIndicator3', '0.1') before import to ensure that the right version gets loaded.

  from gi.repository import AppIndicator3 as appindicator
/usr/bin/slimbooktouchpad:19: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
  from gi.repository import Notify as notify
Traceback (most recent call last):
  File "/usr/bin/slimbooktouchpad", line 29, in
    icono = int(config.get('CONFIGURATION', 'icono'))
  File "/usr/lib/python2.7/ConfigParser.py", line 618, in get
    raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'icono' in section: 'CONFIGURATION'

¿Debería haber más archivos, además del de configuración, en la carpeta slimbooktouchpad?



1
STAFF

staff

Re:Fallo al instalar Slimbook Touchpad
joanslimbook On Martes, 09 Mayo 2017

Hola,

En tu caso falta el parámetro icono que se añadió en la actualización

[CONFIGURATION]

velocidad = 10

deccon = 1

decad = 1

hor = 0

conf = 0

icono = 1



0

experto

Re:Fallo al instalar Slimbook Touchpad
Alex On Jueves, 11 Mayo 2017

¡Funciona! Muchas gracias ;)