Aviso: La filosofía de este foro público de preguntas y respuestas, es que sea participativo. Pretendemos que la comunidad de usuarios de nuestros portátiles compartan su experiencia. Queremos ayudarles y a la vez recibir ayuda para mejorar. Gracias por participar, entre todos hacemos de este un lugar mejor.

 

Para más información sobre el sistema de puntos pulsa aquí


0

iniciado

Problema Hibernar Katana 2

Alexandro Fortes Silva On Viernes, 06 Abril 2018.
Categoría: Linux

Buenas tardes,

He intentado sin éxito activar la hibernación en el katana 2 con Ubuntu 16.04. Paso a detallar lo que he hecho a ver si me podéis dar algo de luz.

He ejecutado la opción de activar hibernación en ubuntu que viene dentro del programa slimbook essentials. La opción me marca que ya tengo la opción de hibernar activada pero no es así. 

Al intentar ejecutar el comando que debería hibernar el equipo me devuelve el siguiente error 

sudo systemctl hibernate

Failed to hibernate system via logind: Sleep verb not supported

Despues de indagar en foros parece que es un problema de que el UEFI está activado y esto no soporta hibernar.

sudo cat /sys/power/disk

[disabled]

 

Todo esto me ha llevado a intentar desactivar UEFI pero no lo he conseguido. Cuando en la bios selecciono Security/Secure boot/Attemp Secure Boot y lo seteo a disabled no parece detectarme el disco duro devolviendome el siguiente error.

Reboot and select proper boot decive or insert boot media in selected boot device and press a key

He intentando encontrar otra opción en la bios pero no la he visto.

¿Cómo puedo activar la opción de hibernar? ¿Como puedo desactivar el secure boot en mi versión de la bios y que me detecte el disco duro? (La versión de mi bios no parece coincidir con los tutoriales que he visto.)

 

Muchas gracias por la ayuda.

 

Un saludo

 

 

 

Todas las respuestas

12 Respuestas.

0

experto 2

Re:Problema Hibernar Katana 2
Antonio Jesús García González On Sábado, 07 Abril 2018



0

experto

Re:Problema Hibernar Katana 2
gallego On Sábado, 07 Abril 2018

No se si serán los drivers de la gráfica, pero si es el mismo hardware que KDE 2, es la misma gráfica y la misma placa, la de Intel; sólo cambia la carcasa.

Lo del UEFI no es el problema, se puede hibernar con UEFI. Y además lo de UEFI no puedes cambiarlo, si instalas un sistema en modo UEFI o Secure Boot no puedes cambiarlo en la BIOS, por que si no ya no detecta el sistema de arranque del disco y tienes que dejarlo como estaba o volver a instalar.



0

iniciado

Re:Problema Hibernar Katana 2
Alexandro Fortes Silva On Domingo, 08 Abril 2018

En primer lugar, muchas gracias por las respuestas. Paso a comentar los avances y el estado actual.

He consegudo deshabilitar el modo UEFI y el fichero /sys/power/disk ya muestra lo siguiente. 

[platform] shutdown reboot suspend test_resume

Después de volver a ejecutar la utilidad de slimbook esential ya ha aparecido el botón de hibernar, aunque no funciona correctamente.

Cuando pulso el botón hibernar el ordenardor parece que se pone en modo hibernar (se apaga la pantalla y el teclado) pero el problema viene cuando intento volver de ese estado. Le doy al botón de encendido y el ordenador parece hacer un encendido normal (se muestra el grub y y acaba cargando el sistema, pidiendo el login y no parece haber guardado el estado antes de hibernar).

He probado el systemctl hibernate para ver si me logeaba algo más de información pero el resultado es el mismo y no me deja información.

También he intentado instalar los ultimos controladores INTEL pero no parece haber disponible ningun controlador alternativo para mi modelo.  ¿Sabeis si los controladores INTEL vienen instalados por defecto en el katana 2? ¿Es normal que no aparezca nada en controladores alternativos?  

Por otro lado tambien he estado revisando el tamaño de mi partición swap y he observado que tiene de capacidad la mitad de mi memoria RAM (Yo tengo 16 GB de RAM y 8GB de swap). ¿Puede ser el problema que no tenga suficiente capacidad en la swap para almacenar el contenido que tengo en memoria en el momento de hibernar?

¿Alguna idea de como puedo obtener más infomación para acotar el problema?

¿Habéis conseguido hacer funcionar la función de hibernar en vuestros Katana 2?

 

Un saludo y gracias !



0

experto 2

Re:Problema Hibernar Katana 2
Antonio Jesús García González On Domingo, 08 Abril 2018



0

experto

Re:Problema Hibernar Katana 2
gallego On Lunes, 09 Abril 2018

Hola,

Si al arrancar el ordenador, sigue sin dejarte hibernar, no es la swap, porque en ese momento no debes tener más de 1Gb de RAM ocupado.

Es curioso, porque hay quien dice que la swap tiene que ser el doble de la RAM, pero claro 32 Gb de swap en un SSD.....es tirar el dinero! En realidad ubuntu quitó la hiberanción por defecto por los problemas que da en muchos casos....y creo que es ilógico que si al hibernar se guarda la ram y la swap, en swap....que pasa si tienes llegan la ram y la swap??



0

iniciado

Re:Problema Hibernar Katana 2
Alexandro Fortes Silva On Lunes, 09 Abril 2018

Buenas a todos, paso a respoder a cada uno

El procedimiento que me comentas Antonio Jesús es el mismo, o similar que el que ya realiza la apliación de slimbook essential. Ya está realizado y el botón de hibernar aparece pero no funciona correctamente.

Por otro lado, gallego, estoy de acuerdo contigo y no deberia ser problema del tamaño de la swap.

Realmente la función de hibernar me daria un poco igual si el katana en suspensión no consumiera tanta batería. Estamos hablando de que en 4 horas suspendido me consume al rededor de un 30% de batería o incluso más.

Vosotros tenéis unos consumos tan altos en modo suspensión? Hay algo que pueda hacer?



0

experto

Re:Problema Hibernar Katana 2
gallego On Martes, 10 Abril 2018

A mi me suspende bien y suspender no suelo hacerlo, porque vuelve tan rápido de hibernar, que prefiero no gastar batería. Aunque no hue mirado el consumo, pero he encotrado este hilo:

https://slimbook.es/foro/tag/PRO/question/2899-consumo-bateria-slimbook-pro2-modo-suspension

Creo que el consumo es cosa de los ssd.... creo...



0

iniciado

Re:Problema Hibernar Katana 2
Alexandro Fortes Silva On Martes, 10 Abril 2018

me puedes decir que pasos has realizado para habilitar la función de hibernar? que tamaño de swap tienes?



0

experto

Re:Problema Hibernar Katana 2
gallego On Martes, 10 Abril 2018

pues creo usé la aplicación de Slimbook, y tengo 16 de ram y 8,5 de swap.



0

iniciado

Re:Problema Hibernar Katana 2
Alexandro Fortes Silva On Martes, 10 Abril 2018

gracias por la respuesta @gallego.

¿podrías pasarme tu /etc/default/grub para ver como lo tienes configurado?

¿Utilizas controladores adicionales?

 

 

 



0

experto

Re:Problema Hibernar Katana 2
gallego On Martes, 10 Abril 2018

No uso drivers adicionales, no me salen disponibles en ubuntu, aunque si que tengo añadido el respositorio de las Beta de Mesa, aunque ya me hibernaba antes.

https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

En cuanto al grub te advierto que no está limpio, lo estuve tocando para otra cosa y al final lo dejé así:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nohz=off pci=noaer acpi_os_name=Linux acpi_osi=Linux"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"



0

experto 2

Re:Problema Hibernar Katana 2
Antonio Jesús García González On Jueves, 12 Abril 2018

Personalmente no lo he probado con Ubuntu pero con KDE Neon me funciona bien el suspender y el hibernar. De todas formas, faltan 2 semanas para que salga la versión 18.04 LTS y seguramente tenga mayor soporte para UEFI.