Notice: The philosophy of this public forum of questions and answers, is that it is participatory. We would like that our user community can share their experience with their laptop. We want to help you and also receive help to improve. Thank you for your participation, and together we will make of this a better place.


0

iniciado

Slibook pro: KDE: kwin_x11 consumiendo mucha CPU

ab On Saturday, 22 July 2017.
Category: Linux

Hola,

He notado que en mi nuevo slimbook pro con KDE Neon el ventilador se pasaba demasiado tiempo encendido a alta velocidad. Inspecionando los procesos observé que el proceso kwin_x11 consumia mucha CPU (20%, que supongo equivale al 80% de un solo núcleo) incluso sin ninguna aplicacion abierta en el escritorio. La solución que encontŕe (no sé si la óptima) fue cambiar el Rendering Backend del Compositor en:

System Settings > Hardware > Display and Monitor > Compositor >  Rendering Backend > cambiar OpenGL 2.0 a XRender

¿Alguien ha tenido un problema similar? ¿Qué soluciones habéis aplicado?

 

Todas las respuestas

5 Answers.

0
STAFF

staff

Re:Slibook pro: KDE: kwin_x11 consumiendo mucha CPU
alejandro On Saturday, 22 July 2017

Hola ab,

Estamos ahora mismo en Akademy (clic aquí), con los desarrolladores de KDE Neon, y no, no es normal un consumo tan alto de CPU en ese proceso.

¿Te has dado cuenta si sucede desde que inicias el SO, o pasa cuando entras en alguna aplicación? Necesitaríamos más información.

Un saludo,



0

iniciado

Re:Slibook pro: KDE: kwin_x11 consumiendo mucha CPU
ab On Saturday, 22 July 2017

Gracias por tu rápida respuesta. Lo he restaurado a Open GL 2 (similar comportamiento con Open GL 3)
A juzgar por el moderado sonido del ventilador, diría que ya sucede antes de hacer login (he esperado varios minutos para hacer login y el ventilador, auqnue no está al máximo, se sigue notando).

Abriedon solo la Konsole para ejecutar top y dejándolo en reposo, el consumo de ese proceso ronda el 8%.
Al realizar cualquier acción gráfica como un click en un menú, sube rápidamente al 70% para volver a bajar progresivamente (si no hago nada más).

Reproduciendo vídeo, el proceso consume cerca del 100% de la CPU y se nota en el ventilador. Además, es fácil observar "tearing" en el vídeo (se mezclan fotogramas separados por una línea ligeramente diagonal). En la configuración del compositor el vsync está en automatic. He probado todos los de la lista sin grandes diferencias. Lo único que lo ha resulto es el cambio a XRender. ¿Hay alguna desventaja respecto a Open GL?


top - 13:11:07 up 14 min,  2 users,  load average: 2.00, 1.30, 0.69
Tasks: 191 total,   1 running, 189 sleeping,   0 stopped,   1 zombie
%Cpu(s): 32.9 us,  5.4 sy,  0.0 ni, 61.6 id,  0.0 wa,  0.0 hi,  0.0 si,  0.0 st
KiB Mem : 16339600 total, 12822968 free,  2069380 used,  1447252 buff/cache
KiB Swap: 16686076 total, 16686076 free,        0 used. 13755968 avail Mem

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND               
 1547 xxx      20   0 3361132 265308  80204 S 101.0  1.6   6:04.57 kwin_x11              
 1929 xxx      20   0 1555512 162252  44748 S  29.6  1.0   1:58.22 mpv                   
 1255 root      20   0  610648 378060 160932 S  23.9  2.3   1:40.12 Xorg                  
 1747 xxx      20   0  695552  82328  69200 S   1.0  0.5   0:05.29 konsole               
 1888 xxx      20   0  762684  82300  65464 S   0.7  0.5   0:05.14 smplayer              
 1517 xxx      20   0 1227432  63972  48188 S   0.3  0.4   0:01.04 kded5                 
 1554 xxx      20   0  0.254t 351432 124948 S   0.3  2.2   0:43.15 plasmashell           
 1581 xxx       9 -11  507300  12284   9284 S   0.3  0.1   0:01.02 pulseaudio            
 1774 xxx      20   0 2683376 728276 143268 S   0.3  4.5   0:39.71 firefox               
    1 root      20   0  185360   5920   3912 S   0.0  0.0   0:01.02 systemd               
    2 root      20   0       0      0      0 S   0.0  0.0   0:00.00 kthreadd              
    4 root       0 -20       0      0      0 S   0.0  0.0   0:00.00 kworker/0:0H          
    6 root      20   0       0      0      0 S   0.0  0.0   0:00.00 ksoftirqd/0           
    7 root      20   0       0      0      0 S   0.0  0.0   0:00.28 rcu_sched             
    8 root      20   0       0      0      0 S   0.0  0.0   0:00.00 rcu_bh        



0
STAFF

staff

Re:Slibook pro: KDE: kwin_x11 consumiendo mucha CPU
alejandro On Saturday, 22 July 2017

Hola,

Una pregunta simple, pero por arrojar un poco más de luz, has probado un LiveUSB de KDE Neon, para descartar que se trate de alguna actualización o aplicación instalada que haya configurado mal.

Gracias,



0

iniciado

Re:Slibook pro: KDE: kwin_x11 consumiendo mucha CPU
ab On Saturday, 30 September 2017

Confirmo que se soluciono el problema reinstalando el SO.
Muchas gracias.



0
STAFF

staff

Re:Slibook pro: KDE: kwin_x11 consumiendo mucha CPU
pepeslimbook On Monday, 02 October 2017

Hola ab,

Me alegro de que tu problema este solucionado, y gracias por compartilo en el foro, así si le ocurre a alguien mas podrá encontrar la solución rápidamente.

Saludos