Notice: The philosophy of this public forum of questions and answers, is that it is participatory. We would like that our user community can share their experience with their laptop. We want to help you and also receive help to improve. Thank you for your participation, and together we will make of this a better place.


0

experto

[SOLUCIONADO] Problema touchpad al despertar de la suspensión

algar On Thursday, 07 December 2017.
Category: Linux
Tags:

Hola:

como ya se ha comentado en este foro, en kérneles recientes de linux el touchpad (modelos  classic y Katana) falla tras despertar el equipo de una suspensión. A pesar de que ya existen varios hilos tratando de esta cuestión, he decidido abrir uno nuevo porque ninguna de las soluciones propuestas en los otros hilos me sirve. Mi distribución es opensuse leap 42.1 y la versión del kérnel es  4.14.3-1.ga731a45-default.

He conseguido resolver el problema mediante el procedimiento que describo a continuación y que tal vez sirva en otros casos:

-El touchpad falla debido a que al despertar el equipo el kérnel le cambia al mouse el protocolo por alguna razón. El protocolo se puede ver mirando el contenido del fichero:

/sys/bus/serio/devices/serio1/protocol

El contenido correcto de este fichero es el string ImExPS/2 pero al despertar de la suspensión se cambia a algo diferente. Para que vuelva a funcionar lo que hay que hacer es ejecutar lo siguiente desde la consola de root:

$root sh -c 'echo -n "exps"' > protocol

Con esto el  touchpad recupera su funcionamiento normal (nótese que hay 3 COMILLAS antes del símbolo >). Aparentemente sólo hace falta hacer esto tras la primera suspensión. Si se vuelve a suspender más veces el problema ya no sucede (creo) aunque no pasa nada si se aplica el comando anterior después de cada suspensión.


¿Alguien me podría por favor indicar una manera automatizada de aplicar lo anterior? Gracias.

 

 

 

Respuesta más votada


17
STAFF

staff

Re:Problema touchpad al despertar de la suspensión
alejandro On Friday, 08 December 2017

Hola algar,

Muchas gracias por tu aporte. Es festivo y no tengo aquí ningún Classic o Katana, pero se me ocurren 2 cosas que podrías probar, las 2 son para indicar el protocolo del touchpad, a ver si así tras la suspensión se aplicar correctamente.

Prueba 1, el grub:

sudo gedit /etc/default/grub

Cambias la línea:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Por esta:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.proto=exps"

Cierras y luego:

sudo update-grub
reboot

Prueba 2, modprobe:

sudo su -
echo options psmouse proto=exps > /etc/modprobe.d/psmouse.modprobe
reboot

Cómo te decía no puedo probarlo, y como sabes el error está reportado a Ubuntu, pero a ver si indicándolo en algunos ficheros se fuerza la configuración.

Un saludo,


Todas las respuestas

13 Answers.

17
STAFF

staff

Re:Problema touchpad al despertar de la suspensión
alejandro On Friday, 08 December 2017

Hola algar,

Muchas gracias por tu aporte. Es festivo y no tengo aquí ningún Classic o Katana, pero se me ocurren 2 cosas que podrías probar, las 2 son para indicar el protocolo del touchpad, a ver si así tras la suspensión se aplicar correctamente.

Prueba 1, el grub:

sudo gedit /etc/default/grub

Cambias la línea:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Por esta:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.proto=exps"

Cierras y luego:

sudo update-grub
reboot

Prueba 2, modprobe:

sudo su -
echo options psmouse proto=exps > /etc/modprobe.d/psmouse.modprobe
reboot

Cómo te decía no puedo probarlo, y como sabes el error está reportado a Ubuntu, pero a ver si indicándolo en algunos ficheros se fuerza la configuración.

Un saludo,



0

experto

Re:Problema touchpad al despertar de la suspensión
algar On Friday, 08 December 2017

Hola Alejandro:


he probado el método del grub y hasta ahora me está funcionando. El método de modprobe no es aplicable en mi caso porque psmouse no está compilado como un módulo en mi kernel.

Gracias por tu rápida respuesta.

 



0
STAFF

staff

Re:Problema touchpad al despertar de la suspensión
alejandro On Friday, 08 December 2017

De nada,

A ver si más #slimbookeros nos pueden confirmar que funciona.

Un saludo,



0

intermedio

Re:Problema touchpad al despertar de la suspensión
Samuel Requena Barral On Friday, 08 December 2017

A mi el primer método tambien me ha funcionado, estoy en un Katana :)



0

intermedio

Re:Problema touchpad al despertar de la suspensión
antonio On Friday, 08 December 2017

Hola.

A mi también me ha funcionado lo del kernel.

Primero he probado la segunda opción (psmouse.modprobe) y eso no me ha funcionado.

 

También me ha funcionado (pero temporalmente) lo primero que decía algar. En ubuntu:

sudo sh -c 'echo -n "exps" > /sys/bus/serio/devices/serio1/protocol'

 

Muchísimas gracias, algar y Alejandro!!



1
STAFF

staff

Re:[SOLUCIONADO] Problema touchpad al despertar de la suspensión
alejandro On Saturday, 09 December 2017

Gracias Samuel y Antonio también por avisar.

Mientras Canonical soluciona el bug, hemos creado un tutorial con los pasos, que aunque son muy sencillos estarán más a mano en un tutorial. Ya que el hilo del foro se caerá mucho más abajo en algunas semanas, y si formateáis el ordenador, hay que volver a seguir estos pasos.

Link: https://slimbook.es/tutoriales/linux/271-solucion-problema-touchpad-no-funciona-despues-de-suspender-o-cerrar-la-tapa-del-slimbook



0

experto

Re:[SOLUCIONADO] Problema touchpad al despertar de la suspensión
Alberto On Sunday, 10 December 2017

Hoy se me acaba de actualizar el Kernel creo que ya lo han solucionado



0

iniciado

Re:[SOLUCIONADO] Problema touchpad al despertar de la suspensión
Jesus_Escribano On Tuesday, 12 December 2017

A mi también  me ha funcionado el método grub (con un Katana). 

Voy a actualizar el kernel ... crucemos los dedos :-)

Gracias por el tutorial

Jesús

 



0

intermedio

Re:[SOLUCIONADO] Problema touchpad al despertar de la suspensión
Javier Muñoz Fuentes On Wednesday, 13 December 2017

Hola a tod@s. "Prueba 1" ha funcionado en mi Katana, ¡gracias!

 

Un saludo,

 

Javier 



0

iniciado

Re:[SOLUCIONADO] Problema touchpad al despertar de la suspensión
Pedro On Wednesday, 20 December 2017

Confirmo que a mí también me ha funcionado en un Slimbook classic.

Gracias!



0

iniciado

Re:[SOLUCIONADO] Problema touchpad al despertar de la suspensión
Iyán Méndez Veiga On Monday, 25 December 2017

Confirmo que la solución propuesta funciona. Para los usuarios de Archlinux que no usan GRUB sino systemd-boot, la solución es muy similar, pero el archivo que tenéis que editar está en `/boot/loader/entries`.

Basta con añadir `psmouse.proto=exps` al final de la línea que pone options.

Un saludo,

Iyán



0

iniciado

Re:[SOLUCIONADO] Problema touchpad al despertar de la suspensión
Miguel On Wednesday, 03 January 2018

¡Muchas gracias! El método del grub me ha funcionado.



0

iniciado

Re:[SOLUCIONADO] Problema touchpad al despertar de la suspensión
José Ignacio On Thursday, 12 April 2018

Yo tenía el mismo problema con mi KATANA, y el método del grub me ha funcionado.

Uso Linux Mint 18.3, y actualizar el kernel no me funcionaba.

De hecho, no sólo el cursor se me iba a la derecha, sino que si lo intentaba sacar de ahí con el Touchpad, empezaba a crearme carpetas nuevas sin ton ni son por todo el escritorio.

¡Muchas gracias!